Nici o versiune de potrivire găsite pentru @ ngrx / core @ ^ 6.1.0

voturi
-1

Sunt modernizarea meu unghiulare 4 până la 6 unghiulare de aplicare. Am actualizat package.json meu și obtinerea următoarea eroare Nu versiune de potrivire găsite pentru @ ngrx / core @ ^ 6.1.0. Nu sunt sigur ce problema este. Am constatat că este dificil să dau ceea ce ne lipsește dependența. Vă rugăm să găsiți copia Package.json meu de mai jos

Package.json

{
  name: irm,
  version: 1.0.0,
  license: MIT,
  scripts: {
    ng: ng,
    start: ng serve,
    build: npm run lint && ng build,
    build-dev: npm run lint && ng build --watch,
    build-aot: ng build --prod --aot=true,
    build-pdf: ng build --app=pdf,
    test: ng test --reporters=progress --browsers=ChromeHeadless --sourcemaps=false,
    testCI: ng test --watch=false --single-run=true --reporters=junit,progress --browsers=ChromeHeadless,
    lint: ng lint --type-check --format stylish,
    e2e: ng e2e,
    verify: npm run testCI,
    ci: npm install && npm run verify && npm run build
  },
  private: true,
  dependencies: {
    @angular-devkit/core: ^0.8.2,
    @angular/animations: ^6.1.7,
    @angular/cdk: ^6.4.7,
    @angular/common: ^6.1.7,
    @angular/compiler: ^6.1.7,
    @angular/core: ^6.1.7,
    @angular/forms: ^6.1.7,
    @angular/http: ^6.1.7,
    @angular/material: ^6.4.7,
    @angular/platform-browser: ^6.1.7,
    @angular/platform-browser-dynamic: ^6.1.7,
    @angular/platform-server: 6.1.7,
    @angular/router: ^6.1.7,
    @ngrx/core: ^6.1.0,
    @ngrx/effects: ^6.1.0,
    @ngrx/store: ^6.0.0,
    @wtw/platform: 1.0.32,
    angular-esri-loader: ^1.1.0,
    angular2-highcharts: ^0.5.5,
    core-js: ^2.5.7,
    highcharts-histogram-bellcurve: ^0.1.7,
    moment-range: 4.0.1,
    ng2-file-upload: ^1.3.0,
    node-sass: ^4.9.3,
    npm: ^6.4.1,
    rxjs: ^6.3.2,
    xlsx: ^0.14.0,
    zone.js: ^0.8.26
  },
  devDependencies: {
    @angular/cli: ^6.2.2,
    @angular/compiler-cli: ^6.1.7,
    @angular/language-service: ^6.1.7,
    @types/arcgis-js-api: ^4.8.1,
    @types/jasmine: ~2.8.8,
    @types/jasminewd2: ~2.0.3,
    @types/node: ^10.10.1,
    codelyzer: 4.4.4,
    intl: ^1.2.5,
    jasmine-core: ~3.2.1,
    jasmine-spec-reporter: ~4.2.1,
    karma: ~3.0.0,
    karma-chrome-launcher: ~2.2.0,
    karma-cli: ~1.0.1,
    karma-coverage-istanbul-reporter: ^2.0.4,
    karma-jasmine: ~1.1.2,
    karma-jasmine-html-reporter: ^1.3.1,
    karma-junit-reporter: ^1.2.0,
    karma-mocha-reporter: ^2.2.5,
    npm-check-updates: ^2.14.2,
    protractor: ~5.4.1,
    puppeteer: ^1.8.0,
    ts-node: ~7.0.1,
    tslint: ^5.11.0,
    typescript: ~3.0.3,
    awesome-typescript-loader: ^5.2.1,
    cpy-cli: ^2.0.0,
    istanbul-instrumenter-loader: ^3.0.1

  }
}
Întrebat 19/09/2018 la 13:35
sursa de către utilizator
În alte limbi...                            


1 răspunsuri

voturi
0

Pachete Ngrx după cum se menționează în documentația lor la https://github.com/ngrx/platform

@ Ngrx / magazin @ ngrx / efecte @ ngrx / router-magazin @ ngrx / magazin-DevTools @ ngrx / entitate @ ngrx / schema

Legătura cu ghidul de migrare acolo: https://github.com/ngrx/platform/blob/master/MIGRATION.md

Sper că acest lucru vă ajută!

Publicat 19/09/2018 la 22:21
sursa de către utilizator

Cookies help us deliver our services. By using our services, you agree to our use of cookies. Learn more